Kafka Connect MQTT Connector (Source and Sink)

The MQTT connector is used to integrate with existing MQTT servers.

Install MQTT Connector

The MQTT connector is compatible with Confluent Platform from version 4.1 onward; prior versions will not work with this connector.

You can install this connector by using the Confluent Hub client (recommended) or you can manually download the ZIP file.

Install Connector Using Confluent Hub

Prerequisite
Confluent Hub Client must be installed. This is installed by default with Confluent Platform commercial features.

Navigate to your Confluent Platform installation directory and run this command to install the latest (latest) connector version. The connector must be installed on every machine where Connect will be run.

confluent-hub install confluentinc/kafka-connect-mqtt:latest

You can install a specific version by replacing latest with a version number. For example:

confluent-hub install confluentinc/kafka-connect-mqtt:1.1.0-preview

Install Connector Manually

Download and extract the ZIP file for your connector and then follow the manual connector installation instructions.

License

This connector is available under the Confluent Software Evaluation License. You can use this connector for a 30-day trial period. If you are a subscriber, please contact Confluent Support at support@confluent.io for more information.

For more information, see MQTT Sink connector and MQTT Source connector.

Contents: